Unity3D problems with FBX models

Discussion started by lianrasmus

Hi!

I am currently trying to make a game in Unity but have encountered a problem that I've tried to solve for a couple of hours without success.

I've downloaded a package from the Asset Store with a foundation to a game. In this downloaded project the models used for the game is stored in one .FBX file which contains all the individual models. The creator of this package has a method for "re-skinning" these models, where he says that one should open the .FBX in 3DS Max, attach your new model to the old, and then remove the old model.

I've done a character in MagicaVoxel which I then export as an .OBJ and import it to 3DS Max and follow his instructions. But when I export the new .FBX with my new model and test it with Unity the model is super tiny and the colors are wrong. This is especially weird because all the other models are perfectly fine.

Have tried numerous ways, but since I'm new at both Unity, MagicaVoxel and 3DS Max I haven't the skill to solve this problem myself.

Thanks in advance!

Rasmus

Answers

Posted 12 months ago
1

I’m not a Unity expert but from the things I know you seem to be having mismatch in metric units.

If you import something from other 3D package and it was made for example in centimeters and you import it in 3ds max while your system units are in millimeters then a normal character that would measure something like 180cm would get to become something like 18cm.

So you basically need consistently stay in same units all the way.

Maybe try export in cm or meters and see what difference you get.
We also have inches or feet but that is less frequently used.
Some game engines use meters so you need to get the correct info what is used in your case.

About the color changes, most game engines use sRGB color profiling so check if you accidentally have changed something in that line.

Posted 12 months ago
1

This should be your friend https://docs.unity3d.com/Manual/ImportingAssets.html

In 3ds Max go to Customize -> Units setup
make sure the "Generic Units" are selected, then click top button "System Unit Setup"
There choose 1 unit = 1 Meters or Centimeters. Does not matter I prefer Centimeters but Unity uses Meters so it is probably better for you.

Scale your model in 3Ds max to real world size depending on your units. If you set it to Meters and you want your model to be 1 meter tall in unity scale it to 1 unit. (Google "3ds max helpers tape" for measuring)

Export as FBX, in export window make sure in Advanced Options -> Units are set to automatic.
Import in Unity.

--- All of above is preferred workflow but not necessary ----

If you import model in Unity and it is too big or small simply click on that model in Project window under assets. In Inspector window under Model tab you will see many import settings. First one is "Scale factor". If your model is to small change it to 10 or 100 and hit apply button. And that's it.

"Color are wrong" is not very specific so I can't tell what is your problem here. Preferred way is to import textures separately and set your materials in Unity by yourself.

Your answer

In order to post an answer, you need to sign in.

Help