texture maps in substance designer are looking flat in blender suggestions

Discussion started by 512pixel

I have developed my texture maps in substance designer . I am usning the same environemnet map both blender and designer ..The maps is looking very gfalt in blender what could caasuing this issue . you can the map is not flat in designer

Answers

Posted about 2 months ago
1

One problem is that your normal maps are inverted. The default output format for normal maps in Substance Designer is DirectX. Blender uses OpenGL normal map format. The difference is the green channel of the normal map is inverted. You can export the normal maps from Substance Designer in OpenGl format by inserting a "Normal Invert" node before the output normal channel (make sure to set the "invert green" option to True) or you can use Photoshop to invert the green channel. When importing the normal map into blender make sure you set the color space to "Non-Color".

The other problem is that you haven't set up displacement in blender. Substance designer uses Displacement/Parallax-Occlusion. If you are going to use Displacement in blender export your height map from substance designer and follow the steps in the following tutorial.
https://www.youtube.com/watch?v=UkU0-QeWUcU
Otherwise make sure to turn off Displacement/Parallax-Occlusion in Substance Designer( To do this, set the scale to 0 in the shader properties), adjust your normal intensity to your liking, and export the maps.

Your answer

In order to post an answer, you need to sign in.

Help