Wildcat - FBX unit scale does not match. Expected: cm, got: m

Discussion started by lucasbenicio

I'm using blender and I'm always getting this error when I upload. I tried changing the base length unit in blender to cm but it didn't work. Anyone else having this issue?

Answers

Posted 22 days ago
1

I also had this issue and found a solution after inspecting the FBX file with Autodesk FBX Converter. The issue is blender's FBX exporter is broken and you need to adjust some setting before you export it. Here are the steps to solve this annoying problem.

1. Apply all transforms
2. Scale your model by 100x
3. Apply all transforms again.
4. Use these settings in the FBX exporter.
Scale: 0.01
Apply Scalings: All local
Forward: Y Forward
Up: Z Up
Uncheck apply unit

mmz-001 wrote
mmz-001
It's difficult to tell what's causing this issue, however, try changing those steps/values to see what works.
Posted 14 days ago
1

I've had exact same problem when exporting FBX. After long time of uploading-exporting-reuploading I found settings that worked:
Scale: 0.01
Apply scalings: All FBX
Forward: Y
Up: Z
Check "apply unit", "use space transform" and "apply transform"

It also seems like units in project itself have no influence on this issue

mmz-001 wrote
mmz-001
When importing the fbx back into blender, this makes the model 100x smaller, even though the error won't pop up when uploading.
madenbyte wrote
madenbyte
mmz is actually right, it turns your model into small toy. Unfortunately, I figured it out only when QA told me that my texel density was stupidly high. I'll put my new preset settings in a new answer so it will be more noticeable
Posted 10 days ago
0

I've revisited my export preset and this is what it is now:

Scale units in the scene: meters (!)
Scale: 1.00
Apply scalings: All Local
Forward: Y
Up: Z
Check "apply unit", "use space transform" and "apply transform"

Give it a try

Your answer

In order to post an answer, you need to sign in.

Help