3D Model problem - Cinema 4D

Discussion started by 4eprintstudio

Hello everyone. I've one question about problem with models of cars. I've downloaded a few car models from cgtrader (lowpoly) and when I open it in Cinema 4D, everything is okay, there isn't any problems, but when I add exported GLTF/GLB in Three.js I've problem my robot character can pass through those cars. So I don't know is there any problem with model or tag or something else, it would be great if somebody can give me suggestion. P.S. I'm working it for my school work, I don't have a lot of experience in three.js and 3D modelling for web in general. So I hope somebody will help me. Thank you!

Answers

Posted 3 months ago
0

What are you trying to do, its not very clear?

If I understand correctly you want it to recognize your robot and not intersect? GLTF models don't have a collision cage so they don't know there is another model in the same location.

Posted 3 months ago
0

Okay, I'll try to explain better. I'm working on something like small low poly city, so in the streets I've cars which are static, they're don't moving at all, so only thing which is moving is my robot/character, so I've solved problem with buildings I can't pass through buildings, but through car I can, on some car I can pass just when I try from left side of car, on other I can from all sides, on other car I can just from front side, so all cars are the same model but they aren't behave in the same way. Thanks!

Posted 3 months ago
0

Okay, I'll try to explain better. I'm working on something like small low poly city, so in the streets I've cars which are static, they're don't moving at all, so only thing which is moving is my robot/character, so I've solved problem with buildings I can't pass through buildings, but through car I can, on some car I can pass just when I try from left side of car, on other I can from all sides, on other car I can just from front side, so all cars are the same model but they aren't behave in the same way. Thanks!

Posted 3 months ago
0

lol... Again, not enough information.

You have solved the problem with your buildings... I assume this is the same problem, how did you solve it?

Can you upload a video of a screen capture of what you are doing? Without seeing what you are doing its very difficult to interpret what you are talking about.

Your answer

In order to post an answer, you need to sign in.

Help