Objects have non reset transforms

Discussion started by andrei-pavlov

Hello World! The problem is as old as the world. When sending a model for testing in a wild cat, it issues "Objects have non reset transforms". Everything was done according to the documentation, but there is still an error. I looked through the forum, I'm not the only one and the problem is not solved. I managed to send the model, but if I make a slight mistake (put the pivot off the center), but that's not how things are done. Maybe there is already a solution to this problem? Working in Maya

Answers

Posted 16 days ago
0

Just make sure the pivot is at 0,0,0 on all axis with the mesh at the centre and reset transforms - this sets the scale values and rotation values to 100% and 0 respectively on all axis. In 3dsMax you do this with the Reset Xform Utility. In Maya it's done with Freeze Transformations under Modify menu.

andrei-pavlov wrote
Thanks for the answer. But you didn't read my message carefully. Everything that you wrote about, I did. Pivot positioned at the origin (0,0,0), mesh should be placed at the center, above the grid. Model scale: real world, 1 unit = 1 meter. Transforms should be frozen. And after that it's still an error "Objects have non reset transforms: Base"
Posted 16 days ago
0

Could be an error with their system ( very unlikely) or there's indeed a problem with that particular object -"Base" .

andrei-pavlov wrote
If you read the forum topics, then this problem is with many users. And everyone decides differently. it is not clear how to work with them (
Posted 16 days ago
0

Maybe it is indeed an issue with their system, idk . I have seen this topic come up a few times here , that's why I responded based on my personal experience with wildcat.
Some time it might really just be an issue from the software - https://www.cgtrader.com/forum/technical-q-a/non-reset-transforms

andrei-pavlov wrote
Thank you, I will try to communicate with technical support. If I find a solution, then I will unsubscribe on this topic.
Posted 14 days ago
0

This method solved the problem. Exported a model from Maya and successfully uploaded it for review.

Make sure the model is positioned with y up, and makes sure all your scales are set to 100.
So scale your model down to 0.01, freeze transforms, then scale your model up to a 100. In other words, you submit your model with x y and z all being 100. (Make sure you export it in meters as your units. When exporting from Maya, there is a setting that you can use somewhere to manually export in meters)

Your answer

In order to post an answer, you need to sign in.

Help