Buggys Pack Low-poly 3D model

Requires Unity 4.2.0 or higher.

Realistic Buggys kit is a new package which can be used if various Games.

Package contains 4 Buggys.

This product has no reviews yet
Buggys Pack
$20.00
Save with CGTrader Credits
Royalty Free License
3dpowermax
3dpowermax
(28 reviews)
Response 70% in 9.9h
3D Modeling
Low-poly Modeling
Texturing
Hire me
3D model formats
  • Autodesk FBX (.fbx)29.3 MB
3D model details
  • Publish date2016-05-25
  • Model ID#490652
  • Animated
  • Rigged
  • VR / AR / Low-poly approved
  • PBR
  • Geometry -
  • Polygons 0
  • Vertices -
  • Textures
  • Materials
  • UV Mapping
  • Unwrapped UVs
  • Plugins used
Help